Home / GitHub Page

Linux 1.0.99 Webclipper Service status: Not found (LinuxMint)


#1

I installed the latest release, updated webclipper to 1.0.4 an get " Service status: Not found". What can I do, please?


#2

Is Joplin running? And is the service running too?


#3

you need to start the webclipper service itself

“tools > webclipper options > activate”


#4

Yes, so I did:

Schritt 1: Clipper Service aktivieren

Dieser Service erlaubt es der Browser-Erweiterung mit Joplin zu kommunizieren. Beim Aktivieren kann deine Firewall dich nach der Erlaubnis bitten, dass Joplin auf einen bestimmten Port mithört.

The web clipper service is enabled and set to auto-start.

Status: Gestartet auf Port 41184


#5

If you open http://127.0.0.1:41184/ping in a browser does it display something?


#6

Yes, “JoplinClipperServer”


#7

Could you check on this page to see if one of the suggestions fixes your issue? https://joplin.cozic.net/clipper/


#8

One thing that has changed since the last version is that the service is only available on IP 127.0.0.1 so if something is changing this like a proxy or similar it could cause an issue.


#9

When I use chromium webbrowser on the same PC (Linux Mint) with Joplin Web Clipper, it works - but not at the first attempt. I saw, that there was at first no entry in “In Notebook”. After a little bit of fumbling around, it works, but only in chromium webbrowser.

So I think, there is no proxy or something else on this PC, because in chromium webbrowser the Joplin Web Clipper runs.

I deactivated all plugins in firefox. But in Firefox I always see the status “Service status: Not found”. I guess, the problem comes from the firefox release of Joplin Web Clipper.

What can I do else to help solving the problem?


#10

Could you open about:debugging in Firefox, then scroll down to the Joplin extension and click on debugging. Then when you open the extension popup, does any message show up in the console?


#11

Yes, there are messages:

Laden fehlgeschlagen für das <script> mit der Quelle "https://cdn.optimizely.com/js/106541357.js".  thankyou:48
Die Ressource auf "https://www.googletagmanager.com/gtm.js?id=GTM-HBFX&gtm_auth=uY0M3zv4Xi085EiNup-pqA&gtm_preview=env-504&gtm_cookies_win=x" wurde blockiert, weil der Tracking-Schutz aktiviert ist.[Learn More]  thankyou
Laden fehlgeschlagen für das <script> mit der Quelle "https://www.googletagmanager.com/gtm.js?id=GTM-HBFX&gtm_auth=uY0M3zv4Xi085EiNup-pqA&gtm_preview=env-504&gtm_cookies_win=x".  thankyou:1
Die Ressource auf "https://js-agent.newrelic.com/nr-1071.min.js" wurde blockiert, weil der Tracking-Schutz aktiviert ist.[Learn More]  thankyou
Laden fehlgeschlagen für das <script> mit der Quelle "https://js-agent.newrelic.com/nr-1071.min.js".  thankyou:1
Versuch, eine verbotene Kopfzeile zu verwenden, wurde abgelehnt: Connection  908488570-lcs_client_bin.js:193:386
Sync encountered an error - see about:sync-log for the log file.  policies.js:804
Versuch, eine verbotene Kopfzeile zu verwenden, wurde abgelehnt: Connection  908488570-lcs_client_bin.js:193:386
Die Verbindung zu ws://127.0.0.1:12546/ wurde unterbrochen, während die Seite geladen wurde.  app.js:1410:29
context.runSafeWithoutClone called while context is inactive  ExtensionCommon.jsm:300
Content Security Policy: 'x-frame-options' wird wegen 'frame-ancestors'-Direktive ignoriert.  (unknown)
Content Security Policy: Ignoriere unbekannte Option 'none'  (unknown)
Die Ressource auf "https://www.google-analytics.com/r/collect" wurde blockiert, weil der Tracking-Schutz aktiviert ist.[Learn More]  v1.0.95...master
Die Ressource auf "https://www.google-analytics.com/collect" wurde blockiert, weil der Tracking-Schutz aktiviert ist.[Learn More]  v1.0.95...master
Versuch, eine verbotene Kopfzeile zu verwenden, wurde abgelehnt: Connection  908488570-lcs_client_bin.js:193:386
Versuch, eine verbotene Kopfzeile zu verwenden, wurde abgelehnt: Connection  908488570-lcs_client_bin.js:193:386

(Do I have to worry? Does the Web Clipper phone to Addvertizers? Isn’t it strongly open source without dependencies?)

I use dietpi in my network with pihole (DNS and Addblocking). Do I have to whitelist all of these url (google-analytics?)?


#12

I deactivated the dietpi with pihole from the network configuration and restarted the Linux Mint PC. The same problem as before with Webclipper.

The problem doesn’t come from pihole.


#13

Unfortunately I’m not seeing anything in the log that could cause this issue.

(Do I have to worry? Does the Web Clipper phone to Addvertizers? Isn’t it strongly open source without dependencies?)

The debug log includes statements from various extensions and pages so it would come from somewhere else. I’m not doing and won’t do any tracking in the extension or any of the apps.


#14

Perhaps this helps to narrow down the problem:

Question to the community: Is anybody out there who uses Linux Mint with Joplin and a working Joplin Web Clipper in Firefox 60.0.2?

This is my uname -a output:
Linux lenovo 4.13.0-43-generic #48~16.04.1-Ubuntu SMP Thu May 17 12:56:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linu

Maybe this helps to decide, if the problem is in Joplin Web Clipper or in my Linux Mint installation.


#15

It seems to work in Ubuntu for me.

If you open the console (F12), what are the messages in there?


#16

Hi,
I am facing the same error on a Windows 10 PC and on a Mac both running Firefox (60.0.2).
The Chrome version is running without problems.
Could this be related to the firefox extension?


#17

@thiemster, could you try to enable debug mode as described in this page: https://joplin.cozic.net/clipper/ and post the content of the consoles here? I’m keen to fix this bug but I’m not able to replicate it so far.


#18

Today, I also see the same problem in Windows 10 with Firefox.


#19

It seems it is listening on the wrong ports (should be 41184 in both cases).
Here is the result from firefox on Mac.

Addition:
For Firefox on Windows the console output looks almost the same:


#20

I am seeing the same thing on Windows but my Ubuntu 18.04 / firefox seems to work. Also noticed that with debug on it didn’t seem to be looking for the port that Joplin says it is running on. I can use curl to talk to the service from either wsl bash or cmd.exe