Home / GitHub Page

Messed up on enc once and now it keeps encrypting everything?


#1

Sorry for the vauge subject, i couldnt figure how to sum up my situation.
First, thankfully, I have a back so I am safe so to speak.
Second, I just set up nextcloud syncing and thought that I just looked at the encryption page but when I went back to the main window it had a little notice at the top to set the password? So i went to the encrption setup and it showed the set password box with an X in it. I didnt think too much of it so put in a password then save, still a red X, so i tinkered some more, actually reencrypted and that worked in so far as i had gree check but figured i’d just start over so in linux I deleted the ~/.config/Joplin and ~/.config/joplin-desktop directories, deleted the files in my nextcloud account, and restarted to joplin appimage.
I then tried syncing joplin on my other computer (winbox), all notes disappear (since i erased them on my nextcloud account), I restore my backups, sync the winbox and it seemed ok except when I looked on my nextcloud account it had all these encrypted files? On the winbox I didnt set encryption, when I look at all the settings nothing seems to indicate its encrypted, and I am able to view and edit notes but when i sync with nextcloud they show up as encyrpted, and ditto for my linbox, when i nuke the config directries then sync they are encrypted on my linbox?
help! (and thank you!!!)


#2

I’m having a similar issue, would love to see the resolution.