Home / GitHub Page

New Dark Theme in Desktop


#1

I’ve been following the recent additions to Joplin, and I see that since 1.0.115 there has been support for a Dark Theme, and some people have even confirmed how awesome it is! Well, I’d like to figure out how to activate it! I’ve scoured the documentation, the commits, the website, and this forum and haven’t found anything saying how to activate it. So it must be simple, right? Well, I’ve also scoured my install, every option, all the settings, every file, and can’t find anything telling me, or allowing me, to do this! I’m running 1.0.117 on Fedora 28, updated just today using the Joplin_install_and_update.sh script to ensure I’m running the latest.

Anyways, any help would be great! I’d really love to use the Dark Theme!


#2

Oh… wait… nevermind…

As is always the case, the answer is found right after reaching out for help. For others, I’ll explain my issue.

I closed Joplin, I updated Joplin, I opened Joplin… Still no new settings. ~/.joplin/VERSION showed 1.0.117, but Help -> About Joplin still showed 1.0.115.

The issue stems from this newfangled Gnome3 stuff… namely, “minimized to system tray”, except there is no system tray. So I closed Joplin, but I didn’t really close Joplin, but I didn’t actually know Joplin was still running. Once I realized that and ran pidof joplin I found all these processes still running. I guess, in hindsight, I should have at least rebooted before posting here asking for help, as that would have fixed this issue, but seriously, who wants to ruin their system uptime because an electron app isn’t updating?!

Thanks for not eating the newcomer alive for his noobish mistakes :slight_smile:


#3

Welcome to the forum, and may all your problems be solved as quickly as this one. :slight_smile:


#4

It looks like a prayer against the " dark side ", “may the force be with you” :sunglasses: