Home / GitHub Page

Numbered List


#1

Hello, I don’t know if this has been requested/informed already. With the latest versions of Joplin, I’m realising the app tries to be too smart in terms of the way it number the list I create, as Microsoft Word does, which is a bit annoying from my point of view.

So if for example I create a numbered list as follow:
1.
2.
3.
everything looks good, but if I want to introduce a bunch of text in between, or under specific conditions, even if I’m specifying the next number is e.g. 4, the preview reset the numbered list to 1 again. E.g. try to create a note with the following content:
1. bla
bla bla
2.
3.
4.
the preview shows:
1. bla

bla
bla

1. 
2.
3. 

I think it should be much better if the preview just shows the numbers I’m hard-coding in the MD as it allows to create multiple numbered list (one inside others) without having to fight with the way the preview understand the list.

Many thanks and congrats for such a great app, latest releases are simply awesome.


#2

Hmm, you are only partly right, but I agree that this automatic numbering is annoying. Maybe there’s a way to use a setting for that. I’m not sure why this auto-numbering happens. @laurent, is this built into the markdown-html rendering?

Anyway, here’s how it looks in my Joplin:

image

However, if you use empty lines before and after the text, the auto-numbering occurs:

image


#3

I think it also happens if you use the ``` to mention special code in between the numbered list and I use it quite a lot. I’m not in front of my laptop to test it right know but almost sure it happens under this situation too.

Thanks for testing it :slight_smile:


#4

For Markdown issue, the best is to try on https://markdown-it.github.io/ If it’s rendering in one way there, and in a different way in Joplin, there’s probably a bug in Joplin. Otherwise, it’s working as expected.


#5

Will do tomorrow, thanks!


#6

FYI:

Here the test output.


#7

Apparently, numbered lists work fine in Joplin when you indent the text or code in between :

I found the behaviour of Makdown-it quite different from Joplin’s…it always succeeded in displaying a nice numbered list, whatever I tried as input text …
Markdown-it :


Joplin desktop (1.0.135 Windows 10) :

Should we report this as a bug in Github or is it just due to a different Markdown parser ?

___NB :___I am new to Joplin and I didn’t had the chance yet to say thanks to @laurent. Great job ! :slight_smile:


#8

It shouldn’t be. Joplin uses markdown-it. The only thing that is differrent is that Joplin uses the breaks option by default. (check the breaks checkbox on the demo page).

But I’ve noticed a rendering issue. As you can see in my screenshot (first one) above the spacing between Number 3, Text here line 1, Text here line 2, and Number 4 is not correct.


#9

The HTML to MD code will be rewritten into something cleaner from the next version, and it seems as a result this bug has been fixed:


#10

Nice, sounds great.


#11

I lacked this info. Thanks for the update.

Great news :slight_smile:


#12

Last version solves the issue. Many thanks!!